Back
Maintenance

Server OS update

Completed 14 Aug at 06:05am CEST.

ping.photocollect.io
Completed

Maintenance completed

Posted 14 Aug at 06:05am CEST.
Started

Scheduled OS update, downtime of about 5 minutes expected.

Posted 14 Aug at 06:00am CEST.